Using F5 VPN with Ubuntu 16.04

This document assumes that you have Ubuntu/Xubuntu/Kubuntu 16.04 LTS installed. Older versions (like 14.04 or earlier) will not work since the newer F5 fat client requires QT 5.x libraries. It is highly recommended to upgrade to 16.04 first if you are currently using an older version.

1. Install prerequisite packages. Open a terminal window and type the following:

sudo apt-get update
sudo apt-get install libqt5core5a libqt5network5 libqt5widgets5 libqt5sql5 libqt5webkit5

2. Login to the VPN. Go to https://msvpn.mssm.edu/ for school or https://msvpn.mountsinai.org/ for hospital.

3. On the F5 desktop, click on the "Tunnel" icon at the bottom.

4. (Optional) Check for 32-bit or 64-bit OS.

If you're unsure if your host is 32-bit or 64-bit, then run "uname -i". "i686" is 32-bit and "x86_64" is 64-bit:

user@myhost:~$ uname -i
x86_64

5. Download the client.

Below the Tunnel icon, you will get a download menu like this below:

Network Access
Network access client components are required.

1. Download and run the installer.

( ) 32 bit .rpm (Fedora/openSUSE)
( ) 64 bit .rpm (Fedora/openSUSE)
( ) 32 bit .deb (Ubuntu/Debian)
( ) 64 bit .deb (Ubuntu/Debian)

Select the radio button for either 32-bit or 64-bit .deb for Ubuntu/Debian. Then click on the "Download" link below the menu.  Finally select the radio button to save as a file in the browser download dialog.

If you don't see the menu above, then you can download the Ubuntu/Debian client using one of the links below:

linux_f5vpn.x86_64.deb
linux_f5vpn.i386.deb

6. Install the client.

cd ~/Downloads
sudo dpkg -i linux_f5vpn.x86_64.deb
Enter labels to add to this page:
Please wait 
Looking for a label? Just start typing.